Bidx.com partial service outage
Incident Report for
Infotech
Resolved
This incident has been resolved.
Posted
Feb
17
,
2026
-
13:15
EST
Investigating
Our team is currently investigating the issue and working to restore the service. We’ll post an update as soon as we learn more. We apologize for any inconvenience.
Posted
Feb
17
,
2026
-
13:09
EST
This incident affected: Bidx.com.
×
Subscribe to Incident
Subscribe to updates for
Bidx.com partial service outage
via . You'll receive .