Bidx.com Partial Outage
Incident Report for
Infotech
Resolved
This incident has been resolved.
Posted
Feb
17
,
2026
-
11:56
EST
Investigating
The service is experiencing error responses. Our team has implemented a fix. We apologize for any inconvenience.
Posted
Feb
17
,
2026
-
11:47
EST
This incident affected: Bidx.com.
×
Subscribe to Incident
Subscribe to updates for
Bidx.com Partial Outage
via . You'll receive .