A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2025 - 10:59 EDT
Update
We are continuing to investigate this issue.
Posted Aug 19, 2025 - 10:26 EDT
Investigating
The service is experiencing slower than normal response times. Our team is investigating the issue and will post an update when we learn more. We apologize for any inconvenience.