Bid Express degraded service

Incident Report for Infotech

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 09:06 EDT

Monitoring

A fix has been implemented and we are currently monitoring.
Posted Mar 27, 2025 - 09:03 EDT

Identified

The issue has been identified and we are implementing a fix.
Posted Mar 27, 2025 - 08:53 EDT

Investigating

The service is experiencing a partial outage with Digital ID Bids/Solicitations are not loading. Our team is investigating the issue and will post an update when we learn more. We apologize for any inconvenience.
Posted Mar 27, 2025 - 08:49 EDT
This incident affected: bidexpress.com.