Doc Express Signature Page Error
Incident Report for Infotech
Resolved
This incident has been resolved.
Posted Apr 09, 2021 - 15:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2021 - 14:31 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 09, 2021 - 13:46 EDT
Investigating
We are currently investigating this issue.
Posted Apr 09, 2021 - 12:55 EDT
This incident affected: docexpress.com.